Default Software Content Download job with error and CIC commands not working
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Default Software Content Download job with error and CIC commands not working

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Article ID: 221205

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

The Default Software Content Download job shows error constantly and while trying to check if CIC is working, all commands fail with same error:

C:\Program Files (x86)\CA\SC\CIC\bin>Util.bat -c
[com.ca.sccc.CCException] - Exception caught.  Stack Trace:
[com.ca.sccc.CCException] - java.lang.NullPointerException
[com.ca.sccc.CCException] - java.io.File.<init>(File.java:277)
[com.ca.sccc.CCException] - com.ca.sccc.CCConfig.getAndResetLoggingProperties(CCConfig.java:133)
[com.ca.sccc.CCException] - com.ca.sccc.CCBatchUtil.main(CCBatchUtil.java:48)
[com.ca.sccc.CCBatchUtil] - Failed to complete logging configuration
Completed due to Fatal Error (return code: 2)
See Util log file for details

C:\Program Files (x86)\CA\SC\CIC\bin>Util.bat -m "database_server"
[com.ca.sccc.CCException] - Exception caught.  Stack Trace:
[com.ca.sccc.CCException] - java.lang.NullPointerException
[com.ca.sccc.CCException] - java.io.File.<init>(File.java:277)
[com.ca.sccc.CCException] - com.ca.sccc.CCConfig.getAndResetLoggingProperties(CCConfig.java:133)
[com.ca.sccc.CCException] - com.ca.sccc.CCBatchUtil.main(CCBatchUtil.java:48)
[com.ca.sccc.CCBatchUtil] - Failed to complete logging configuration
Completed due to Fatal Error (return code: 2)
See Util log file for details

Environment

Client Automation - All Supported versions

Cause

Reviewing CIC log, the same error is shown:

INFO  [com.ca.sccc.dbm.CCDBManager] - Starting uninitialization of  MDB connection pool for domain 'database_server'
ERROR [com.ca.sccc.CCException] - Exception caught.  Stack Trace:
ERROR [com.ca.sccc.CCException] - java.lang.NullPointerException
ERROR [com.ca.sccc.CCException] - com.ca.sccc.CCConfig.getAndResetLoggingProperties(CCConfig.java:141)
ERROR [com.ca.sccc.CCException] - com.ca.sccc.CCMain.main(CCMain.java:90)
ERROR [com.ca.sccc.CCException] - sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
ERROR [com.ca.sccc.CCException] - sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
ERROR [com.ca.sccc.CCException] - sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
ERROR [com.ca.sccc.CCException] - java.lang.reflect.Method.invoke(Method.java:498)
ERROR [com.ca.sccc.CCException] - org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:240)
ERROR [com.ca.sccc.CCException] - java.lang.Thread.run(Thread.java:748)
FATAL [com.ca.sccc.CCMain] - Failed to complete logging configuration, aborting

Resolution

The FATAL error means that something got corrupted on CIC, this could be caused by a unexpected reboot of the server while CIC was running.

The best way to solve this is to reinstall CIC, procedure explained on this article:

Content Import Client (CIC) manual install

NOTE: Since this is not a database problem, the section that describes how to manually create 'cicuser' can be skipped.