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Clarity Risk Assigned To Notification not being generated for risks created in the New UX

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Article ID: 221204

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Are notifications not enabled for Risks and Issues in the Modern UX? Users do not receive any email when risks are created with the user updated as the Assigned To on the risk. When the same user creates the risk in the classic UX, the user does receive both the email and the notification in Clarity.

Steps to Reproduce: 

  1. Login as admin/admin in new UI 
  2. Navigate to any project (4G Upgrade Readiness) and go to Risks grid 
  3. Click on the + icon ( to add a new row) 
  4. Fill required cell value; i.e., Name, Status, Assigned To, ID, and Priority 
  5. Save the Risk 

Expected Results: User receives an assigned to notification email like "Risk is assigned to you. Risk: New test 2, Investment: 4G Upgrade Readiness".

Actual Results: Initial "Risk is assigned to you" notification email is not generated. 

Cause

DE62134 

Workaround: Reassign risk to different user and assign risk again to original assignee. 

Environment

Release : 15.9.3

Component : CLARITY COLLABORATION (DOC & ACTION ITEMS)

Resolution

Fixed in Release 16.0.0

  • The Email notification is working now for the Assigned user. 
  • The issue has been resolved for Risks, Issues, Change Requests (RICs) even though the issue was only reported for Risks.