Data Loss Prevention rpms package is conflicting with itself

book

Article ID: 221045

calendar_today

Updated On:

Products

Data Loss Prevention

Issue/Introduction

When installing data loss prevention detection server RPMs we see an rpm error that the rpm conflicts with itself.

 

rpm -ivh symantec-dlp-15-8-00000-content-extraction-service-15.8.00000-19012.x86_64.rpm
    file /opt/Symantec conflicts between attempted installs of \
    symantec-dlp-15-8-00000-content-extraction-service-15.8.00000-19012.x86_64 and symantec-dlp-15-8-00000-content-extraction-service-15.8.00000-19012.x86_64.rpm

Cause

This kind of error message can appear if you try to install a package whose previous installation got aborted without completing.

Environment

RHEL 7.x

Resolution

We edited the install.sh script and added --force to the rpm -ivh line. 

  1. Extract the detectionserver.zip
  2. vi install.sh 
  3. Add --force to the rpm --ivh line towards the bottom of the file.
  4.  
  5. Save and exit
  6. Re-run the install. 

Attachments