Users not getting authenticated after accepting the VIP PUSH notification when the VIP Enterprise Gateway push number challenge option is set to disabled
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Users not getting authenticated after accepting the VIP PUSH notification when the VIP Enterprise Gateway push number challenge option is set to disabled

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Article ID: 221015

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Updated On:

Products

VIP Service

Issue/Introduction

Users are getting PUSH notifications on their mobile device but the login screen does not acknowledge the PUSH, or may require the user to click OK to complete the transaction. 

Unable to run the passwordTool.sh to change the local Administrator password on RHEL 8.x.

Environment

VIP Enterprise Gateway 9.11.0

Cause

Adding the Push Number Challenge feature has added an extra Attribute: 92 of len 42 [ACCESS_CHALLENGE_FOR_NUMBER_CHALLENGE_PUSH] which is sent even if that feature is not enabled on the RADIUS server or in VIP Manager.

Resolution

Note: This hotfix should be applied only on VIP Enterprise Gateway 9.11 for Windows and Linux platforms.  This fix has been integrated into 9.11.1 which is now available. If upgrading to 9.11.1 the hotfix is not needed.
 
1. Sending Push Number Challenge custom attribute conditionally, Condition check includes enabling number challenge at e.g. validation server (RADIUS server) and VIP Manager.
2. Fixed the issue with password tool, by adding missing dependency.
 
This patch .zip includes binaries for windows and linux, Please follow instruction based on platform and use platform specific binary.
 
Installation Steps for Windows:
 
Solution:
Download zip and extract the contents to a temporary location  (for example: C:\temp). 
Stop all the validation servers.
Make a backup of the following file.
<VRSN_MAUTH_HOME>/Validation/bin/VSValidationServer.exe
            <VRSN_MAUTH_HOME>/server/bin/vipegtools.jar
            <VRSN_MAUTH_HOME>/version.txt
From the temporary directory where you extracted the binary file contents, copy the following files: 
Copy VSValidationServer.exe to the <VRSN_MAUTH_HOME>/Validation/bin/ 
            Copy vipegtools.jar to the <VRSN_MAUTH_HOME>/server/bin/   
            Copy version.txt to the <VRSN_MAUTH_HOME>/ 
Start the all validation servers. 
 
 
Installation Steps for Linux:
 
Solution:
Download zip and extract the contents to a temporary location (for example. /opt/temp)
Stop all the validation servers. 
Make a backup of the following files. 
              <VRSN_MAUTH_HOME>/Validation/bin/VSValidationServer
              <VRSN_MAUTH_HOME>/server/bin/vipegtools.jar
              <VRSN_MAUTH_HOME>/version.txt
From the temporary directory where you extracted the binary file contents, copy the following files: 
               Copy VSValidationServer  to the <VRSN_MAUTH_HOME>/Validation/bin/  
               Copy vipegtools.jar to the <VRSN_MAUTH_HOME>/server/bin/
               Copy version.txt to the <VRSN_MAUTH_HOME>/ 
Start all the validation servers. 

 

Additional Information

Roll Back Steps for Windows and Linux:
If you encounter any issue after installing this hotfix, use the following steps to revert the changes: 
•    Stop all the validation servers. 
•    Navigate to the location where you backed up the VIP Enterprise Gateway files during installation of the patch and copy the backed-up files to original location.
•    Start the validation servers.

Attachments

VIP_EG_911_BRCMVIP-5862_BRCMVIP-5900_HotFix.zip get_app