To Dos menu item not available even though user has all the rights
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To Dos menu item not available even though user has all the rights

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Article ID: 220891

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After upgrading to 15.9.2, even though that entitled users have all the To Do - * rights, the To Dos menu item does not show in the Modern UX.

Accessing the To Dos page directly shows this error: API-1007 : You are not authorized to process request. Contact your system administrator for necessary security rights.

Also, the user cannot create any new To Do items from tasks. The same error is displayed.

Environment

Release : 15.9.2

Component : Clarity MUX UI Usability

Cause

There could be some missing rights that should be reviewed by Support.

Resolution

Please raise a new case with Support and provide the results from the following query:

SELECT
    cso.object_code,
    csr.right_type,
    csr.permission_code,
    csr.is_active,
    csr.permission_value,
    csr.right_obs_type
FROM
    cmn_sec_objects cso
    JOIN cmn_sec_right csr ON csr.object_id = cso.id
WHERE
    lower(object_code) LIKE '%to%do%'
ORDER BY object_code, right_type, permission_code;

Additional Information

Similarly, if the issue occurs with Pages instead of To Dos, replace the WHERE clause from the query for the following:

WHERE
    lower(object_code) LIKE '%page%'