Datamart Rollup Job Failed - Determine current fiscal period no data found
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Datamart Rollup Job Failed - Determine current fiscal period no data found

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Article ID: 22068

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

This scheduled job failed:

Job: Datamart Rollup - Time Facts and Time Summary

Failed - Message:

java.sql.SQLException: [CA PPM][Oracle JDBCDriver][Oracle]ORA-20000: Error in CMN_JOB_DATAMART_ROLLUP_SP - ORA-20000: Error in NBI_EXTRACT_TF_TS_SP - Determine current fiscal period: ORA-01403: no data found
ORA-06512: at "CLARITY.CMN_JOB_DATAMART_ROLLUP_SP", line 11
ORA-06512: at line 1

Cause

This error message indicates that there is no active, monthly fiscal time period defined for the current month.

Resolution

The Datamart jobs require active, monthly Fiscal Time Periods defined for the Entity that is configured on the Datamart Settings page. The configuration of Fiscal Time Periods must include the current month. It is a 'best practices' recommendation to define active, monthly periods up to 6 months into the future so that the Administrator does not have to remember to create these periods each month.

Once confirmed the fiscal periods are set up and active run the Datamart Extraction job and the the Datamart Rollup job.
If the above solution doesn't work check the time slice setting for the time slice ID=1 {DAILYRESOURCEACTCURVE} which needs to cover 2 years of range 1 in the past and 1 in the future. 

The Datamart Extraction job needs to run first to populate the tables needed for the Rollup job.

Additional Information