SOI Manager not start due to SQL port change
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SOI Manager not start due to SQL port change

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Article ID: 220646

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

After starting the soi manager services, they start running. But SOI doesn't completely start. We have had no recent changes to the environment.

Environment

Release : 4.2

Component : Process Automation

Cause

The reason the SOI manager is not coming online is because it's having a problem connecting to the SQL server with the below error in the soimgr-debug.log file.

 

2021-07-19 10:00:12,872 FATAL [localhost-startStop-1] ?.?(?)  - 2021/07/19 10:00:12:856 GMT-03:00 [FATAL] DatabaseCreator - Failed to create database tables for registry resource store. Cannot create PoolableConnectionFactory (Network error IOException: Connection refused: connect) <org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (Network error IOException: Connection refused: connect)>org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (Network error IOException: Connection refused: connect)

Resolution

Problem was cause by SQL Server setup with new port number.

The SQL Server originally was using port 1433 but they change it.

 


Here are the following files that need to change the SQL port

On SOI Manager Server:

\soi\tomcat\lib\hibernate.cfg.xml
\soi\tomcat\registry\topology\physical\node0\sor\
restserver.xml
sorapp.xml
ssaserver.xml
ssaweb.xml

\soi\ServiceDiscovery\connectivityContext.xml

\soi\wso2registry\repository\conf\
registry.xml
user-mgt.xml

After making the changes, you will need to run
\soi\tomcat\registry\registryloader.bat


On the UI Server:

\soi\wso2registry\repository\conf\
registry.xml
user-mgt.xml