Starting FDM with GTMAPPER.EXE fails with: This application requires a Java Runtime Environment 1.8.0

book

Article ID: 220588

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction


After installing AdoptOpenJDK (build 1.8.0_292-b10) and FDM Fast Data Masker (FastDataMasker-4.9.177.0), it is not possible to start FDM by running GTMAPPER.exe
The following error is shown:
This application requires a Java Runtime Environment 1.8.0

Java has been added to the path environment variable and JAVA_HOME has also been set correctly.
Running 'java -version' from a CMD window shows: 
C:\>java -version
openjdk version "1.8.0_292"
OpenJDK Runtime Environment (AdoptOpenJDK)(build 1.8.0_292-b10)
OpenJDK 64-Bit Server VM (AdoptOpenJDK)(build 25.292-b10, mixed mode)

FDM can be started with: java -jar gtmapper.exe

Environment

Release : 4.9

Component : TDM Fast Data Masker

Resolution

GTMAPPER.EXE checks the following registry key for a Java installation: HKLM\SOFTWARE\JavaSoft\
When installing AdoptOpenJDK enable the JavaSoft registry key option: 

Attachments