Alarm Console Error - An Unexpected error has occurred. Please check logs for details

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Article ID: 220552

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Users reported today that Alarm Console shows the error in the Subject Title - Alarm Console Error - An Unexpected error has occurred. Please check logs for details

Also there are no Alarms displayed in the console.

We have checked the PC logs PCService.log and wrapper.log and we see a similar message like the following.

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ERROR | SpectrumInfoService/Thread | 2021-07-27 08:26:24,275 | com.ca.im.portal.plugins.spectrum.service.SpectrumInfoService
      | Failed to refresh model class enums. Enable debug on com.ca.im.portal.plugins.spectrum.service.SpectrumInfoService for more information
ERROR | SpectrumInfoService/Thread | 2021-07-27 08:26:24,298 | com.ca.im.portal.plugins.spectrum.service.SpectrumInfoService
      | Failed to make request: Moved Temporarily
ERROR | SpectrumInfoService/Thread | 2021-07-27 08:26:24,298 | com.ca.im.portal.plugins.spectrum.service.SpectrumInfoService
      | Failed to refresh trouble shooters. Enable debug on com.ca.im.portal.plugins.spectrum.service.SpectrumInfoService for more information
ERROR | SpectrumInfoService/Thread | 2021-07-27 08:26:55,340 | com.ca.im.portal.plugins.spectrum.service.SpectrumInfoService
      | Failed to make request: Moved Temporarily
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Prior to the errors appearing SAML was enable on the OneClick server that is integrated with Performance Manager as a Spectrum Data Source.

We have tried updating the Spectrum User and Password set in the Spectrum Data Source configuration but no change is seen.

The Spectrum Data Source shows not problems and synch works as expected.

Cause

SAML enabled on the OneClick server that is integrated with Performance Manager as a Spectrum Data Source.

Environment

All supported DX NetOps Performance Management releases

Resolution

To fix this follow the steps in Step 6 of the Enable Single Sign-On section of the Spectrum documentation.

The entry in the non-saml-config.xml file might look something like this for a Spectrum Data Source set with a user named svc_caspectrumit.

This tells Spectrum to utilize basic authentication which allows the restful webservice calls to work.

<?xml version="1.0" encoding="UTF-8"?>
<NonSamlConfig>
  <allowBasicAuthentication>true</allowBasicAuthentication>
  <userName>svc_caspectrumit</userName>
</NonSamlConfig>

NOTE: Ensure the tomcat web services on the OC host integrated with PM are restarted after editing the non-saml-config.xml file. Only a restart of these services will trigger it to re-read this file and it's new changes.

Additional Information

The Spectrum User set in the Spectrum Data Source configuration is used to make restful webservice API calls to Spectrum. These calls are used to retrieve Spectrum Alarm information for the Alarm Console Views in the Performance Management Portal.

The Spectrum restful webservice calls do not support a user that requires SAML authentication. The Spectrum restful webservice calls require a user with basic authentication.