Catalog requires credentials when accessed with IP address

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Article ID: 220460

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Updated On:

Products

CA Service Catalog

Issue/Introduction

We observe that catalog login pop-up comes when we use the IP address of the catalog server for catalog and SDM integration where the behavior is not the same when we use the hostname.

The reason for using IP address is that when we cluster two or more catalog servers it’ll use the IP address of these servers, not the hostname.

Cause

The components are deployed on multiple server (Distributed environment) and the latest browser updates do not allow cross site hand shakes even though they are in the same network

Environment

Release : 17.3

Components : CA SERVICE CATALOG, CA Service Management

Resolution

Ideally a workaround to resolve this issue is by

"created a DNS entry for F5 load balancer VIP and instead of IP use DNS hostname of virtual IP".

Additional Information

Please refer the below doc for additional information:

https://docs.microsoft.com/en-US/troubleshoot/browsers/prompt-for-username-and-password