Running the Symantec Installation Manager failed with error "Symantec Installation Manager has encountered a fatal exception and cannot continue. Please see the log file for more information"
search cancel

Running the Symantec Installation Manager failed with error "Symantec Installation Manager has encountered a fatal exception and cannot continue. Please see the log file for more information"

book

Article ID: 220451

calendar_today

Updated On:

Products

Client Management Suite

Issue/Introduction

When running Symantec Installation Manager, it fails with the error:

Environment

ITMS 8.x

Cause

By checking the logs,  we found 'Access to the path 'C:\PROGRA~1\Altiris\Symantec Installation Manager\Licenses\' was denied'

  • c:\Users\useridusedduringinstall\AppData\Local\Temp\SIM Logs\a.log 

when checking the Altiris folder it shows the warning 'You don't currently have permission to access this folder'

Resolution

Grant the required permissions to the Altiris folder in Program files:

  • Administrator: Full Control
  • System: Full Control
  • Authenticated Users: Read

NOTE:  After looking through the dump from another reporting of this issue the registry contained some unexpected entries in the registry that was related to an obsolete PL (product listing) definition.  Removing the registry key  [HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\Configuration\ProductListings\1] and and relaunching SIM resolved this issue.