RAJ - Rally Adapter for Jira - admin console is not coming up, getting 502 error when installing the integration

book

Article ID: 220369

calendar_today

Updated On:

Products

CA Agile Central SaaS (Rally)

Issue/Introduction

I have installed the airgap version of embedded adapter bundle in my VM, It has enough RAM (32 GB). Though the installation was complete and successful, the adapter seems not stable. It is up and running for only few minutes and It goes unavailable.  When I run the command -  kubectl get pods -n default, Its shows many number of rji-adapter-xxxxxxxx nodes running  but I configured only singled node. 

Also the admin console is not coming up, getting 502 error.

Resolution

1.  Verify that the test environment meets the requirements listed here:  https://techdocs.broadcom.com/us/en/ca-enterprise-software/agile-development-and-management/rally-platform-ca-agile-central/rally/integrating-top/connectors/ppm-integrations/adapter-for-jira.html

2.  Verify that the pre-flight checks had no failures

 

This seems to have been because the user didn't have enough storage. 

The user was able to save the VM by deleting the evicted pods by using a command like: kubectl get pod -n default | grep Evicted | awk '{print $1}' | xargs kubectl delete pod -n default to delete all the Evicted pods at once

 

They are now getting the following error:

When I run kubectl get pods -n default, I see 2/2 running for rji-adapter-xxxxxx-xxxxx but I get 1/1 ready If I run kubectl get deployments rji-adapter.

 

kubectl get deployments rji-adapter

NAME          READY   UP-TO-DATE   AVAILABLE   AGE

rji-adapter   1/1     1            1           6d22h

 

The 2/2 running is because there is a sidecar container that runs for log collection.  So, everything looks good there.