'Installation Failed: Your installer is not working properly' when installing the SEP Mac agent to an Apple Silicon (M1) device..
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'Installation Failed: Your installer is not working properly' when installing the SEP Mac agent to an Apple Silicon (M1) device..

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Article ID: 220288

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Updated On:

Products

Endpoint Protection Endpoint Security

Issue/Introduction

When installing the 14.3 RU2 Endpoint Protection or Endpoint Security Mac agent to an Apple Silicon (M1) device, the installer shows the following error:

'Installation Failed: Your installer is not working properly.'
or in some cases,
'This version of Symantec Agent for Mac is not supported on Apple M1 chip.'



Environment

Apple Silicon (M1) device
Endpoint Protection (on-premises) SEP Mac agent 14.3 RU2
Endpoint Security (cloud-based) SES Mac agent 14.3 RU2

Cause

In certain situations, the Apple operating system may look at the hostArchitectures attribute for a specific package within our universal installer application. This attribute is currently not set properly to show both x86_64 and arm64.

Resolution

This issue is fixed in Symantec Endpoint Protection 14.3 RU3.  For information on how to obtain the latest build of Symantec Endpoint Protection, see Download the latest version of Symantec Endpoint Protection.

To work around this issue please do the following:

- If your Mac device has an outdated version of Rosetta or Rosetta is not properly installed, run the following command on your Mac device before starting the Mac agent installation:   
softwareupdate --install-rosetta

- If the Mac agent installer was enabled to run under Rosetta, uncheck the option Open using Rosetta for Mac agent installer, and then start the installation again.

Additional Information

References:
Known issues and workarounds for Symantec Endpoint Protection (SEP)