AutoSys logs display "ORA-25408: can not safely replay call" errors after enabling debugging
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AutoSys logs display "ORA-25408: can not safely replay call" errors after enabling debugging

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Article ID: 220238

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Updated On:

Products

CA Workload Automation AE - Scheduler (AutoSys)

Issue/Introduction

When enabling debugging with the ISDBGACTIV=DBQUERY option, "ORA-25408: can not safely replay call" errors are seen in the AutoSys Scheduler log.

Environment

All Supported Versions of WAAE

Cause

These errors are returned by the Oracle Clients local to the AutoSys Scheduler/App Servers. It is generally an issue in the Oracle RAC/TAF configuration where a database insert is interrupted. The interruptions are usually cause by idle connections being dropped and reestablished or by database node failovers.

Resolution

AutoSys 11.3.6 was updated to handle this type of exception and attempt the insert again as documented here:

https://support.broadcom.com/download-center/problem-detail.html?productcd=ATSYS&problemnbr=4813

As of 11.3.6, this can be safely ignored as AutoSys reattempts the insert where the above Oracle exception is received.