Custom Rollup patch (CR) created with New Based On are in status Unknown
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Custom Rollup patch (CR) created with New Based On are in status Unknown

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Article ID: 220131

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Patch Manager

Issue/Introduction

CR patch (Custom Rollup) created using "New Based On" are automatically set in status "Unknown"

Environment

Client Automation - All Versions

Cause

This problem could occur if there are some archived SD Package in Software Package Library

Type = Generic (Archived)

Resolution

Solution for Client Automation 14.0 SP3, 14.5 and 14.5 CU1 :

Open a case at CA Broadcom Technical Support requesting the fix T55V224
 
Remark : The fix T55V224 has been included in patch CU2. So another solution is to apply CU2 or a more recent patch.

 

Workaround if fix T55V224 is not installed :

Workaround 1 :

Restore all archived SD Packages
 
 
 

Workaround 2 :

* On Domain Manager stop caf
caf stop
 
* Execute following SQL Query on mdb database
use mdb
update usd_rsw
set itemtype=5, archcomment='ARCHIVED'
where itemtype=6
 
This will change the type of the archived packages from Archived to detected packages.
 
Remark:
The correct type could be restored with this query :
update usd_rsw
set itemtype=6, archcomment=''
where itemtype=5 and archcomment='ARCHIVED'
 
* Start caf
caf start