Symantec Identity Manager - Bulk Load in CA Identity Portal through CSV not loading entire column
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Symantec Identity Manager - Bulk Load in CA Identity Portal through CSV not loading entire column

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Article ID: 220053

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Updated On:

Products

CA Identity Suite CA Identity Portal

Issue/Introduction

When uploading CSV files through Identity Portal with data that contains spaces in any column is causing only the last word in that column to be presented to Identity Portal upon load.

Example: attribute value in First Name is  
ABC test XYZ

After loading it is assigning the last word in the column. In the above example, this means that the users First Name would be XYZ when the desired outcome is ABC test XYZ

Environment

Release : 14.X

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Cause

Identity Portal is not able to escape the spacing on its own.

Resolution

When loading attributes with special characters such as a (space) it is a best practice load that attribute with double quotes around it.

When using the above example, loading the First Name as ABC test XYZ caused only XYZ to be presented to IP but if the attribute was modified to "ABC test XYZ" with the CSV then the entire word would be imported properly into IP.

Non-working: ABC test XYZ

Working: "ABC test XYZ"