Java.lang.OutOfMemoryError: Java heap space while upgrading the Virtual Appliance Client Tools
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Java.lang.OutOfMemoryError: Java heap space while upgrading the Virtual Appliance Client Tools

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Article ID: 220037

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Updated On:

Products

CA Identity Suite

Issue/Introduction

While trying to upgrade the Virtual Appliance Client Tools from 14.3 to 14.3 CP2, the process is getting stuck at 72% during the Bulk Load client up-gradation

 

 

Environment

Vapp 14.3

Cause

Exception in thread "ANT-EventQueue-0" Java.lang.OutOfMemoryError: Java heap space

Resolution

The Installer was not moving further from the beginning and a scan of Installer LAX log files in the temp directory revealed heap memory error "Exception in thread "ANT-EventQueue-0" Java.lang.OutOfMemoryError: Java heap space"

 

Run the below command with the following parameters should work fine.

 

VirtualApplianceTools.exe -jvmxms 128m -jvmxmx -1024

 

The problem is with the installation of the Bulk Loader. The upgrade of this is unable to handle files replacement in the JVM folder. Usually, the JVM folder is in the installed path i:e C:\Program Files (x86)\CA\Identity Manager\Bulk Loader\jvm.

 

We need to remove/rename this JVM folder and upgrade it again.