Scheduled exports intermittently fail to be delivered
search cancel

Scheduled exports intermittently fail to be delivered

book

Article ID: 219970

calendar_today

Updated On:

Products

Information Centric Analytics

Issue/Introduction

Scheduled dashboard exports are not delivered. Scheduling an export to be delivered within the next two minutes may succeed, however.

In some cases, the following error message is captured in the table RiskFabric.dbo.ScheduledExport_TasksHistory:

Cannot access a disposed object.  Object name: 'Chromium process; EndPoint=; State=Disposed'.

Environment

Release : 6.x

Component : Scheduled Exports

Cause

Internet Information Services (IIS) requires a running worker thread in order for scheduled exports to run. If enabled, the IIS application pool setting Idle Time-out (minutes) will idle-out all threads when there's no activity after the specified period of time.

Resolution

Modify the value of the setting Idle Time-out (minutes) in IIS for the RiskFabric application pool from 20 to 0 (disabled):

  1. On the Information Centric Analytics application server, open the Internet Information Services (IIS) Manager
  2. In the Connections pane, select Application Pools
  3. In the list of Application Pools, right-click the pool named RiskFabricAppPool and select Advanced Settings
  4. In the Advanced Settings window in the Process Model section, locate the setting Idle Time-out (minutes) and change its value to 0
  5. Click the OK button
  6. Right-click the RiskFabricAppPool and select Recycle

NOTE: In some cases, disabling the Idle Time-out setting is insufficient to correct this behavior. This is most common when ICA is being used solely to generate reports. Under these circumstances, you must enable and configure the IIS sub-feature Application Initialization. Instructions for doing so are provided in the Microsoft document IIS 8.0 Application Initialization.