UPM Patch in Package Failed - Verification has failed
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UPM Patch in Package Failed - Verification has failed

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Article ID: 219931

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Patch Manager

Issue/Introduction

When downloading a Patch in Patch Manager, it goes in packaging fails.

In C:\Program Files (x86)\CA\DSM\PatchManagement\PMEngine.log following error could be seen :

This is an example for file upmrollup.ini but it could occur for any files :

2021-07-19 11:15:44,231 [Dloader-3] INFO  [com.ca.pmengine.dlm] - Attempting file extraction to: C:\Program Files (x86)\CA\DSM\PatchManagement\downloads\d15b6449-24c5-46b8-ad69-eff3dc6c4961
2021-07-19 11:15:45,028 [Dloader-3] INFO  [com.ca.pmengine.dlm] - Patch: upmrollup.ini {d236a456-aabd-4785-a685-9fe6f500e1d0} Beginning  download
2021-07-19 11:15:47,184 [Dloader-3] INFO  [com.ca.pmengine.dlm] - Patch: upmrollup.ini {d236a456-aabd-4785-a685-9fe6f500e1d0} Download completed successfully
2021-07-19 11:15:47,231 [Dloader-3] ERROR [com.ca.pmengine.dlm] - Patch: upmrollup.ini {d236a456-aabd-4785-a685-9fe6f500e1d0} verification failed
2021-07-19 11:15:47,231 [Dloader-3] ERROR [com.ca.pmengine.dlm] - Verification of upmrollup.ini has failed.

Environment

Client Automation - All Versions

Cause

This problem could occur if MD5 checksum stored in database for the file is different than calculated MD5 checksum of downloaded file.
 
Cause could be :
- Problem during download of the file (eg: Web Proxy has blocked the download)
or
- Problem with checksum stored in database

Resolution

1- Execute following SQL Query to check the checksum and size stored in database
 
Replace 
CA - Patch Me - Security IntelliRollup v2107.00
and
upmrollup.ini
with appropriate value
 
SELECT name, size_in_bytes, checksum, download_url FROM ca_download_file
WHERE install_pkg_uuid=(SELECT install_pkg_uuid FROM ca_install_package WHERE ipkg_name like '%CA - Patch Me - Security IntelliRollup v2107.00%')
and name='upmrollup.ini'

 

In above example the file upmrollup.ini from patch "CA - Patch Me - Security IntelliRollup v2107.00" has size of 2173772 bytes and checksum 6adde255bd122227c5736a459093d5e3 in database
It is downloaded from https://ftpdocs.broadcom.com/WebInterface/phpdocs/0/ClientAutomation/Content/PatchTuesday/2107/intelli/OS/PatchMe/upmrollup.ini
 
 
 
2- Try to download manually the file with provided url.
And check its size and checksum with command :

certutil -hashfile upmrollup.ini MD5

 

3- If checksum is different that one in database and size is the same or with a small difference, then problem is in database.
 
Try to execute again "Default Software Contents Download Job" in SystemEngine or manually with :
 
cd /D C:\Program Files (x86)\CA\SC\CIC\bin
run.bat
 
Then execute the SQL Query of step 1 and check if checksum is corrected.
If checksum is still not correct, open a case at CA Broadcom Technical Support to have it corrected.

If the patch needs to be urgently downloaded, following SQL Query could be executed to correct the checksum in database :

UPDATE ca_download_file
SET checksum='checksum calculated in step 2 by certutil'
WHERE install_pkg_uuid=(SELECT install_pkg_uuid FROM ca_install_package WHERE ipkg_name like '%CA - Patch Me - Security IntelliRollup v2107.00%')
and name='upmrollup.ini'

And try again the download of Patch

 

4- If checksum is different that one in database and size is much smaller, rename the downloaded file by adding .html at the end (upmrollup.ini.html) and open this file in an Internet Browser. It may be an error message sent by ProxyWeb.

This could also be done with file downloaded by Patch Manager

C:\Program Files (x86)\CA\DSM\PatchManagement\downloads\d15b6449-24c5-46b8-ad69-eff3dc6c4961\upmrollup.ini.html