Provisioning task failed with Unable to authenticate to Connector Server error
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Provisioning task failed with Unable to authenticate to Connector Server error

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Article ID: 219912

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

Provisioning tasks failed in Identity Manager and application server log shows the following error.

15:01:22,220 ERROR [im.provisioning.account] (default task-2) Error while retrieving the account. This could be due to unavailable endpoint.Failed to load properties [groups, emailAddress, middleName, active, faxNumber, logonID, department, roles, company, userName, firstName, jobTitle, lastName, phoneNumber]: javax.naming.AuthenticationException: [LDAP: error code 49 - :ETA_E_0020<RAC>, User Account '<Account Name>' on '<Endpoint Name>' read failed:Unable to authenticate to Connector Server: ldaps://<Connector Server Name>:20411 ]; remaining name 'eTDYNAccountName=<Account Name>,eTDYNAccountContainerName=Accounts,eTDYNDirectoryName=<Endpoint Name>,eTNamespaceName=<Endpoint Type>,dc=im,dc=eta'

 

 

Environment

All Identity Manager

Cause

Wrong credential to access Connector Server

Resolution

Use Connector Xpress tool to re-register the Connector Server using the correct password.

Launch Connector Xpress, connect to the Provisioning Server,
  1. Right click the affected Connector Server registration item under CS Configs and select Edit CS Config.... Screen capture the configuration and then close.
  2. Right click the affected Connector Server registration item under CS Configs and select Delete CS Config....
  3. Right click the CS Configs node and select New CS Config... to re-register the Connector Server and specify the correct password.

  4. Make sure all the configuration is restored as what has been captured at step 1.
  5. Restart Provisioning Server