Customized Processes and RPC not reaching Background Server in (AA) environment
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Customized Processes and RPC not reaching Background Server in (AA) environment

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Article ID: 219908

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

After the upgrade the customized processes that trigger ITPAM workflow was not running. ITPAM Workflow associated with Activity Notification From SDM

Environment

Release : 17.3 Production 

Component : SVC DESK UPGRADE

Cause

RPC was not reaching to the Background server. Recycling PDM services did not restart SPELSRVR services. When spelsrvr remain in status of "Running" the process of recycling SDM services does not register in NX.env file. No change in NX.env means No change happening or nothing to log in jstd log or jsrvr log

Resolution

The important steps taken to resolve this case was removing and reinstalling all the SDM/ITPAM integration Options from >Administration>Option Manager section shown in image below. Renaming user ID and resetting the password options was the key part of this resolution because the other options has been removed and added back several times during the span of our troubleshooting, but the issue persisted. The username and password options were initially skipped because customer did not want to tamper with ITPAM side of the equation as the user "<USERID>" and its password is being used for ITPAM process. But during the final attempt, we renamed <USERID> to something totally different with simple password and we renamed it back to "<USERID>" and the correct password. The customized workflow process and requests started flowing to ITPAM.