System forced memory trace dump whren the access to a Client is not valid
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System forced memory trace dump whren the access to a Client is not valid

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Article ID: 219848

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

AWA generates unforced memory trace dumps occasionnally with no direct impact on the production.

The traces show that

20210428/132108.240 - U00003631 Dump caused by:
20210428/132108.240 - U00003517 UCUDB: Invalid DB-STMT IND: '0' at OPC: 'CLST'
20210428/132108.240 - U00011801 Error in Server routine 'JPEXEC_R', Server: 'JMS_IDST#WP018' AE system: 'JMS_IDST'.

Enabled TCP=2 and Database=4 show the following cause in the traces:

20210608/122238.776 - U00005009 AgentGroup 'HG.BASIS.00.OS_DB_ER_BRCONN': invalid client access rights for the host 'L9738022'.
20210608/122238.776 - UCUHG Exit SIMU RET: 5009 Time: 0:008.233.206 Client: 0009 HG_Idnr: 01159711 Count: 00000000 PosSelected: 00000000 Mode: A HGName: HG.BASIS.00.OS_DB_ER_BRCONN MaxParallel: 00000000
20210608/122238.776 - UCUDB32 CLST RET 3517 HSTMT: 0000000000000000 VALUE: 0000000000000000 ALL: 0.00001 DB: 0.00000 ODBC: 0.00000 UDB: 0.00001
20210608/122238.776 - UCUDB32 CLAL RET 0000 HSTMT: 0000000000000000 VALUE: 0000000000000000 ALL: 0.00003 DB: 0.00000 ODBC: 0.00000 UDB: 0.00003
20210608/122238.776 - U00003620 Routine 'JPEXEC_R' forces trace because of error.

Environment

Release : 12.3

Component : AUTOMATION ENGINE

Cause

The forced Traces are generated because a Agent from the Agent Group (HOSTG) does not have access rights to a specific client.

This behavior is a bug. In this or in a similar situation the Engine must no throw a forced trace.

Resolution

Workaround:

Provide the referenced agent in the U00005009 message access to the client where HOSTG object is active

Resolution:

This is a bug fixed in 12.3.7, released in October of 2021