OPMS update proxy
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OPMS update proxy

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Article ID: 219744

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Updated On:

Products

CA App Synthetic Monitor

Issue/Introduction

 

During the upgrade of the OPMS to release 10.7 many monitors in ASM were affected.

When the incident has been solved, some of the monitors were still failing. After checking it, the failure is caused by having the check "use the proxy" in ASM advanced settings.

These monitors were working correctly before the incident/upgrade, and no monitor settings were modified  during the incident/upgrade.

The use system proxy option was removed and the monitors run again.

It has only happened on monitors running in the Internal OPMS.

Is it possible that the upgrade of the OPMS version could explain this?

 

Environment

Release : 99.0

Component : APP SYNTHETIC MONITOR ENVIRONMENTAL

Cause

 
A defect was fixed in 10.7 (DE507026) where the 'Use system proxy' setting was ignored for Script monitors.
 
The explanation is that a monitor was configured with a script that is intended to work without a proxy, and the user unintentionally checked the 'use system proxy' option. 
 
The monitor was working because the option did not take effect.
 
Now that the fix is in place, the proxy setting is applied, and the monitor fails because the customer's proxy blocks the requests in the script.
 

Resolution

 

If script monitors start failing after OPMS 10.7 upgrade, please make sure this setting is not enabled in the Advanced section of monitor settings