Jaspersoft 7.8 Fails to Start After Install or Upgrade
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Jaspersoft 7.8 Fails to Start After Install or Upgrade

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Article ID: 219658

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

The CSA > Reporting page shows the Jaspersoft server as 'Unavailable'. In tomcat_home\webapps\reportservice\WEB-INF\logs\jasperserver.log an error is thrown:

 java.lang.UnsupportedClassVersionError: com/jaspersoft/jasperserver/multipleTenancy/configuration/JaaSNewUser has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0 (unable to load class [com.jaspersoft.jasperserver.multipleTenancy.configuration.JaaSNewUser]) [com.jaspersoft.jasperserver.multipleTenancy.configuration.JaaSNewUser]

Environment

Release : Any

Cause

The JRE_HOME is not referencing the JDK 11 directory.

Resolution

1. Set the JRE_HOME to the JDK home directory

It should be set as follows:

2. Save and restart Jaspersoft