Trying to set up a Ping alert on a network device and it never works
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Trying to set up a Ping alert on a network device and it never works

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Article ID: 219654

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Updated On:

Products

IT Management Suite Server Management Suite

Issue/Introduction

Trying to get a Ping alert to a network device working.  A ping alert to computers works fine, but not to a network device.   

 

Environment

Release: Monitor Solution 8.5 RU3

Cause

The root cause is Site Server assignments 

Resolution

A quick check can be done by running this query against CMDB:

SELECT ParentItemGuid
FROM ItemReference
WHERE Hint = 'monsiteserverresources' AND ChildItemGuid ='GUID-of-Site-Server'

If in the output you do not see the network device resource you are trying to monitor, it will also not be delivered to the Remote Monitor Server (RMS) as part of the agentless monitor policy.

The easiest solution is to create a manual assignment of resources (specific target) to a specific Site Server (RMS) you'd like to use for pinging the remote resources.  To do this, in the Site Server Settings expand Site Servers and select a specific Site Server:

Settings > Notification Servers > Site Server Settings > Site Servers 

On Manually Assigned Agents click the New button and select the resource target that contains Network Resources to monitor:

Run a full membership update and again check the query above - it should then contain all the resources.  After that RMS should receive an updated policy (with resources) and start monitoring.

Settings > Notification Server > Resource Membership Update > Complete update schedule