Agent Windows 12.3.6 File Transfer hangs in Transferring with big files causing Force Traces in WPs
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Agent Windows 12.3.6 File Transfer hangs in Transferring with big files causing Force Traces in WPs

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Article ID: 219648

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Agent Windows 12.3.6 has issues when being the Source to send files bigger than 1MB via JOBF( issue reproduced with a file having a size of 1.9MB)
The Job remains in Transferring Status and transfer is not performed:


If the target Agent is also Windows Agent 12.3.6  no Report is available and in the Agent Log we find these kind of errors:

20210714/151506.620 - U00011407 FT '1831034': File transfer with partner 'AGENT_WINDOWS_2' has started.
20210714/151506.620 - Sender Session started, with async settings (30,60,5)
20210714/151506.825 - U00011410 FT '1831034': Transferring file 'C:\temp\WPsrv_trc_001_00.txt'.
20210714/151507.307 - U00011479 FT '1831034': Unable to start new file transfer session. Error: '1831034'.
20210714/151507.307 - U00011492 FT '1831034': Connection with partner 'AGENT_WINDOWS_2' will be closed. Error: 'unexpected close of socket'.
20210714/151507.307 - U00011409 FT '1831034': File Transfer has ended abnormally.



If the target Agent is a Unix agent, you will find this kind of errors:

2021-07-15 11:15:39 - U02000063 Connection to Agent 'AGENT_LINUX' with connection data '[::1]:2401' not possible. Error code '10061', error description: 'No connection could be made because the target machine actively refused it.'.
2021-07-15 10:15:13 - U00011124 Selection started with filter 'D:\installer\Continuous.Delivery.Automation_12.3.4_2020-10-21\install.sh' ...
2021-07-15 10:15:13 - U00011125   'D:\installer\Continuous.Delivery.Automation_12.3.4_2020-10-21\install.sh'
2021-07-15 10:15:13 - U00011126 Files selected: '1'.
2021-07-15 10:15:13 - U00011409 FT '1831037': File Transfer has ended abnormally.


In the Automation Engine, some WPs may produce Force traces as below:

7/15/2021 12:16:42 U00015006 System forced memory trace dump.
7/15/2021 12:16:41 U00003422 WARNING: Cannot load conversation memory '0029d3b6' for server routine 'JPEXEC_R'.
7/15/2021 12:16:41 U00011801 Error in Server routine 'JPEXEC_R', Server: 'AUTOMIC#WP009' AE system: 'AUTOMIC'.

 

Environment

Release : 12.3

Component : AUTOMATION ENGINE

Sub-component: Agent Windows

Cause

Problem introduced in Agent Windows 12.3.6, not existing in version 12.3.5

Resolution

Workaround 1:

Rollback the Agent Windows to version 12.3.5 or inferior

Workaround 2:

Increase the BufferSize parameters from default 1MB to 4MB in the INI file of ALL the impacted Agents performing JOBF replacing the existing values

sendBufferSize=4194304
recvBufferSize=4194304

Then restart the impacted Agents to take into account the modification.

Solution

Update to a fix version listed below or a newer version if available.

Fix version:
Component(s): Agent Windows 

Automation.Engine 12.3.7 - Available