ATC unable to connect to DB
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ATC unable to connect to DB

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Article ID: 219645

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Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

After upgrading APM from 10.5.2 to 10.7, unable to connect to ATC. It shows a blank page.

From EM logs:

[ERROR] [Thread-39] [Manager.AppMap] DB version is 10.5.2.0, while your application has version 10.7. Denying to start ATC.

Environment

Release : 10.7.0

Component : Postgres DB

Cause

 DB upgrade was not successful.

Resolution

EM was upgraded from 10.5.2 but either APM DB version was not upgraded at the same time or APM DB upgrade was not successful.

In Postgres connect to the APM DB with pgadmin or command line psql  check the version with this SQL:

select ts_db_versions from ts_domains;

If it does not show "10.7.0.0" then need to run 10.7 EM Installer with "Database Only option".

Additional Information

Team Center is showing blank screen because Database is  disconnected. Try to connect database again either start the database or provide right credentials in config/tess-db-config.xml file.