Portfolio sync: Unknown error
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Portfolio sync: Unknown error

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Article ID: 219539

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After upgrading Clarity to 15.9.2, the Portfolio Sync action is failing with Unknown error.

What could be behind the error?

Cause

The Portfolio Investment object Attribute Registry is corrupted

Resolution

Go to Studio > Objects > Portfolio Investment object

Go to the Attribute Registry tab.

Take a screenshot of the attributes added and remove all of them.

Try a Portfolio Sync action. This should now be successful now.

Add the fields back to the Attribute Registry.

You might notice that some fields were previously added are not available any more. These might be orphan records referring to attributes that are not available any longer because they were deleted/renamed ... and were not updated accordingly on the Attribute Registry

Additional Information

bg-ca.log file shows the following error:

ERROR 2021-06-09 09:58:15,424 [Dispatch Synchronize portfolio investments : bg@myserver (tenant=clarity)] job.PFMSyncManager (clarity:myuser:58190259__5D2622B9-3872-40E9-98CE-BFAC182EBEF6:Synchronize portfolio investments) 
com.niku.union.odf.exception.ODFException: com.niku.union.persistence.PersistenceException: An error occurred getting statement: odf-pmd.pfm_investment.update-sqlcurve.odf_ca_inv from resolver

 

Issue can also be caused when lookups being used in power filters on the 'Portfolio -  'Contents Editor' page do no not populate values.