Opening Outlook is extremely slow when Symantec DLP is installed
search cancel

Opening Outlook is extremely slow when Symantec DLP is installed

book

Article ID: 219501

calendar_today

Updated On:

Products

Data Loss Prevention Data Loss Prevention Endpoint Prevent

Issue/Introduction

Outlook is extremely slow to open, navigate, and send email on a handful of virtual desktops that have the Symantec Data Loss Prevention (DLP) endpoint agent installed.
This is seen when Outlook monitoring is not enabled in the Agent Configuration. 

Environment

Symantec DLP 15.7 MP1
VDI server: Citrix 1912 LTSR Applications and Desktops
VDI OS: Windows 10 2019 LTSC (1809 Long term service channel)
Office O365 (2016)

Cause

The Citrix API hook caused incompatibility issues with the Symantec DLP agent.

Resolution

Disable the Citrix API hooks for Outlook.
Reference: https://support.citrix.com/article/CTX107825
 
For Windows 64-bit version

Keys:
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\CtxHook
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\CtxHook
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\CtxHook64

Value Name: ExcludedImageNames
Type: REG_SZ
Value: outlook.exe


A reboot is needed after disabling the hooks.

 

 

Additional Information

Note: The registry change may need to be applied to the Master Image during the testing phase.