XFlow server not accessible.
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XFlow server not accessible.

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Article ID: 219454

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

End users are unable to login to xFlow, despite service restart

Environment

Release : 17.3 and higher

Component : SERVICE DESK MANAGER

Cause

The following logging is of interest

Excerpt from stdlog (SDM install dir\logs): 
=================

06/30 14:40:32.20 [sdm-server] domsrvr:02             14768 ERROR        sec_mgr.c             4030 Unable to find DomSession 1036184907 used by user IS_SSXFlowAccount invoked by play_service_15268@[sdm-server] with reply method got_sync_fetch

06/30 14:40:33.08 [sdm-server] bpvirtdb_srvr          21236 SIGNIFICANT  socket_port.c         1956 Unable to write to (domsrvr:03) for 813 seconds. Total errors (29217). Last RC(10035): Unknown error

06/30 14:40:36.58 [sdm-server] boplgin                19824 ERROR        bplaccess.c           3434 AHD04013:Internal error in method (got_ldap_domset): LDAP agent not found 

Excerpt from incidentms.log (C:\Program Files\CA\xFlow\APPS\logs): 
=====================

ERROR - 2021-06-30 14:32:54 [c.c.c.a.h.SdmBoplginMethodHelper] - Exception getting authentication token : ReceiveTimeout

ERROR - 2021-06-30 14:32:54 [c.c.c.actor.SdmBoplginMethodActor] - Timeout receiving response for the message: ; [Method: validate_external_user]; [Arguments: IS_SSXFlowAccount, domsrvr:03, 12, ]
INFO - 2021-06-30 14:32:54 [c.c.c.a.impl.NTLMAuthenticator] - Completed validateExternalUser method invocation

ERROR - 2021-06-30 14:32:54 [c.c.c.actor.SdmBoplginMethodActor] - Timeout waiting for slump response: ReceiveTimeout

ERROR - 2021-06-30 14:32:54 [c.ca.casm.framework.util.CasmFuture] - Exception occurred, see call stack for more details: userid ()java.util.concurrent.CompletionException: com.ca.casm.exception.CasmBaseException: NTLM Authentication failed

....

ERROR - 2021-06-30 14:32:54 [c.ca.casm.framework.util.CasmFuture] - Exception occurred, see call stack for more details: userid ()
java.util.concurrent.CompletionException: com.ca.casm.exception.CasmBaseException: Failed to authenticate user: AHD04013:Internal error in method (got_ldap_domset): LDAP agent not found

Resolution

casm_active_session table contained many stale sessions. 

Solution is to truncate the casm_active_session table. 

Stale sessions had been caused by the usage of the webservices call, Requested to explicitly call Delete function once sessions are created.

Additional Information

Truncation of the casm_active_session table should be done via direct DB access, removing the oldest entries (based on the creation_dt and last_access_time fields) and performed after taking a backup of the database first.