Target Resolution Date rule is not honored in Issue Module 
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Target Resolution Date rule is not honored in Issue Module 

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Article ID: 219236

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Problem Statement:  As per documentation Target Resolution Date in Risk/Issue/Changes- Defines the date for resolving the issue. The date must be the same or earlier than the impact date field. This is working for Risk but not working for Issues. 

  • In Risk when you set Target Resolution Date later than Impact Date the  warning "ITL 0002 - Target Resolution Date be the same or earlier than the impact date comes on the page.

Steps to Reproduce: 

  1. Login to Clarity with appropriate rights 
  2. Create or use an existing Project 
  3. Create an instance of Issue and set the Target Resolution Date after the impact date 

Expected Results: The Target Resolution Date should be same or earlier than the impact date.

Actual Results: The Target Resolution Date can be set beyond the impact date in Issue module. 

Environment

Clarity 15.9.X

Cause

DE61755, was reported because it allowed the Target Resolution Date to be after the Impact Date.

The intended design was to be that the Target Resolution Date should be the same as or before the Impact Date. 

Resolution

  • Fixed in Release 16.0.0 
  • The validation is now enforced for both Risks and Issues when both fields are used together. 
  • There are other combinations of use for these two fields that do not invoke the validation. 
  • If there is a value in the Impact Date, the Target Resolution Date can remain blank, or if a value is entered, the validation rule is applied. 
  • If there is NO value in the Impact Date, the validation rule is NOT applied to the Target Resolution Date and it can be any date specified.  

Additional Information

Reference the Release 16.0.0 online product documentation for the topic of Project Risks, Issues, Change Requests, and Action Items 

  • The Target Resolution Date in Risks or Issues is defined as the date for resolving the issue.
  • The date must be the same or earlier than the Impact Date field. Change Requests do not have an Impact Date or Target Resolution Date. 
  • The Impact Date is defined as the date this Risk or Issue will impact the Investment schedule if it is not resolved or mitigated; it is NOT the date the Risk or Issue is created. 
  • The Target Resolution Date is the date for which the Risk or Issue is resolved or mitigated. 
  • The Target Date must occur on or before the Impact Date.