ASM - OPMS - api.log getting written to /tmp directory
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ASM - OPMS - api.log getting written to /tmp directory

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Article ID: 219019

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Updated On:

Products

CA App Synthetic Monitor

Issue/Introduction

We have an OPMS instance running on a Linux server.

The api.log is getting written to /tmp directory.

Why is this?

It is causing the OS /tmp directory to fill pretty quickly.

Environment

Release : SAAS

Component : APP SYNTHETIC MONITOR ENVIRONMENTAL

Cause

The /tmp/api.log file should only contain the startup logs and is hardcoded in the startup script to /tmp/api.log.

However, it is duplicating all logs that are also in /var/log/smartpop/api.log.

Customer can safely get rid of that log by manually editing the init script

/etc/init.d/smartpop-api

Resolution

Customers can safely get rid of that log by manually editing the init script

/etc/init.d/smartpop-api
and modifying this line:

daemonize -o /tmp/api.log -e /tmp/api.log -u $USER -c $PROJECT $DAEMON $DAEMONARGS || return 2

to

daemonize -u $USER -c $PROJECT $DAEMON $DAEMONARGS || return 2

i.e. removing -o file -e file parameters that redirect the standard output and standard error output to /tmp/api.log