WSS agent UI status not updating when Windows logged in username contains special characters
search cancel

WSS agent UI status not updating when Windows logged in username contains special characters

book

Article ID: 218982

calendar_today

Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

WSS agent 5.x, 6.x and 7.x up to 7.3.x

User account on Windows host includes special extended characters e.g. Elniño

When this user is logged in with WSS agent is installed and becomes active, the 'Status' tab in the WSS agent UI does not get updated

Reconnect button works, and the WSS agent is actually connected (as seen in the diagnostic log) - but the UI is not updated.

 

Environment

All WSS agent releases prior to WSS 7.3.x

Only happens on Windows - not an issue on macOS, as the OS doesn't allow you to specify usernames with special characters.

Cause

Bug with the WSS agent handling extended characters in username

Resolution

To be fixed in WSS agent builds post 7.3.x.