A critical error occurred: No connection could be made because the target machine actively refused it <Local IP Address: Port>
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A critical error occurred: No connection could be made because the target machine actively refused it <Local IP Address: Port>

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Article ID: 218899

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

An Altiris Administrator is trying to run a repair on his ITMS 8.1 RU7 implementation but as soon as it starts reconfiguring, he gets this error:

A critical error occurred:

No connection could be made because the target machine actively refused it <Local IP Address: Port>

Configuration failed while attempting: to configure the Notification Server...

The SIM logs show the following entries:

Entry 1:

Symantec.Installation.ConfigureNS.StartCurrentTask: starting configuration task Configure Notification Server....
-----------------------------------------------------------------------------------------------------
Date: 30/06/2021 15:11:16, Tick Count: 6978046 (01:56:18.0460000), Size: 377 B
Process: SimConsole.dll (7556), Thread ID: 21, Module: SimConsole.dll.exe
Priority: 4, Source: Symantec.Installation.ConfigureNS.StartCurrentTask

Entry 2:

ConfigureNS - task_Completed(): Configuration Task Configure Notification Server... Failed: Unable to connect to the remote server
Unable to connect to the remote server
   [System.Net.WebException @ System]
   at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)
   at System.Net.HttpWebRequest.GetRequestStream()
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Altiris.NS.Installation.ProductConfigurationWebServiceProxy.ConfigureProductBatchForUpgradeWithoutSQL(String[] paths)
   at Symantec.Installation.UpgradeConfigTask.<StartImpl>d__2.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Symantec.Installation.NSConfiguration.Tasks.SerialTask.<Start>d__0.MoveNext()

No connection could be made because the target machine actively refused it ##.###.##.###: ##
   [System.Net.Sockets.SocketException @ System]
   at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
   at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

Exception logged from: 
   at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
   at Symantec.Installation.ConfigureNS.task_Completed(Object sender, CompletedEventArgs e)
   at Symantec.Installation.Task.OnCompleted(Exception ex)
   at Symantec.Installation.NSConfiguration.Tasks.SerialTask.<Start>d__0.MoveNext()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Runtime.CompilerServices.AsyncMethodBuilderCore.MoveNextRunner.Run()
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()


-----------------------------------------------------------------------------------------------------
Date: 30/06/2021 15:11:18, Tick Count: 6980078 (01:56:20.0780000), Size: 2,71 KB
Process: SimConsole.dll (7556), Thread ID: 14, Module: SimConsole.dll.exe
Priority: 1, Source: Symantec.Installation.ConfigureNS.task_Completed

Entry 3:

User prompt request: 'A critical error occurred:
No connection could be made because the target machine actively refused it ##.###.##.###: ##

Configuration failed while attempting: Configure Notification Server...': Result: OK (handled by user)
-----------------------------------------------------------------------------------------------------
Date: 30/06/2021 15:11:23, Tick Count: 6984734 (01:56:24.7340000), Size: 510 B
Process: SimConsole.dll (7556), Thread ID: 14, Module: SimConsole.dll.exe
Priority: 8, Source: Symantec.Installation.Automation.Output.ReportVerbose

Entry 4:

Symantec Management Platform 8.1 (8.1.4528) configuration has failed.
-----------------------------------------------------------------------------------------------------
Date: 30/06/2021 15:11:23, Tick Count: 6984734 (01:56:24.7340000), Size: 331 B
Process: SimConsole.dll (7556), Thread ID: 14, Module: SimConsole.dll.exe
Priority: 1, Source: Symantec.Installation.ConfigureNS.task_Completed

Environment

ITMS 8.5, 8.6

Cause

IIS service was not running. The following error appears on IIS Manager when the customer tries to start the IIS service:

This website cannot be started. Another website may be using the same port.

In this particular scenario, IIS (under the Default Web Site) had 2 bindings for the same port.

Resolution

This issue can be resolved as soon as the IIS service can start.

Try the following:

  1. Open IIS Manager, Go under Default Website>Bindings


  2. Delete the duplicate binding for port 443:



  3. Start IIS service



  4. Go back to SIM and start the upgrade/repair/reconfigure process one more time.