During installation, the Scheduler starts despite selecting : "Start the scheduler following installation: N"
search cancel

During installation, the Scheduler starts despite selecting : "Start the scheduler following installation: N"

book

Article ID: 218857

calendar_today

Updated On:

Products

CA Workload Automation AE

Issue/Introduction

When installing an AutoSys Scheduler, the installer gives you a choice of whether to start the Scheduler after installation or not:

Start the scheduler following installation: Y/N

A case was reported where the Scheduler started and ran for approx 20 seconds before stopping again, despite the following install selections:

Scheduler Properties:
   Set scheduler to start at system startup: Y
   Start the scheduler following installation: N

The database was not empty, as it had been copied over from another instance. This caused jobs to run for a period of about 20 seconds.

Environment

Release : 11.3.6

Component : CA Workload Automation AE (AutoSys)

Cause

If you select EEM Security as part of the installation, the Scheduler does get start and run briefly in order to register AutoSys to EEM. If there are jobs defined in the AutoSys database, some jobs may be triggered.

The following is an example where this occurred.

According to install logs, after the Scheduler was installed, the installer did evaluate that the Scheduler should not be started:

10:03:56 ++  -- WA: In function: startScheduler
10:03:56 ++  -- WA: SCHED: Installed. Checking to see if it should be started.
10:03:56 ++  -- WA: SCHED: Not configured to be started.

However, in order to activate EEM, the Scheduler was indeed temporarily activated:

10:03:56 ++  -- WA: In function: isSchedUp
10:03:56 ++  -- WA: Activating EEM. However, the scheduler is not active.
10:04:03 ++  -- WA: In function: isSchedUp
10:04:04 ++  -- WA: The scheduler has been temporarily activated.
10:04:04 ++  -- WA: In function: isAppSvrUp
10:04:04 ++  -- WA: Activating EEM. However, the application server is not active.
10:04:11 ++  -- WA: In function: isAppSvrActive
10:04:11 ++  -- WA: Checking to see if the application server has started...
10:04:11 ++  -- WA: Checking 1 of 15 times...
10:04:17 ++  -- WA: Checking 2 of 15 times...
10:04:21 ++  -- WA: The application server has been temporarily activated.
10:04:21 ++  -- WA: (4) Activating CA EEM security...
Command: autosys_secure -e -host host1.company.com,host2.company.com  -secadmu EiamAdmin -p ********
10:04:22 ++  -- WA: CA EEM security has been activated for this instance.
10:04:22 ++  -- WA: Stopping the scheduler...
10:04:38 ++  -- WA: Stopping the application server...

It was during those moments that the Scheduler was active for approx 20 seconds. 

Resolution

If you select EEM activation during installation, there is no way to avoid the Scheduler being activated temporarily to activate EEM. 

The best way to avoid unwanted jobs being triggered by the Scheduler in the above scenario would be to follow one of these two install paths:

1) Point your new AutoSys installation to an empty database. The installation will activate the Scheduler for a few seconds to register to EEM, but no jobs will run as the database will not contain any. After the installation, you can copy over the data to the new AutoSys database.

2) Select Native Security during the installation and activate EEM post-install using the as_safetool method as documented here:
https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/autosys-workload-automation/12-0-01/reference/ae-commands/manage-security/as-safetool-command-manage-the-repository-of-ca-eem-security-policies.html