sla_engine doesn't start after enabling TLS v1.2 against MS SQL
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sla_engine doesn't start after enabling TLS v1.2 against MS SQL

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Article ID: 218853

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

 

After enabling TLS v1.2 for Microsoft SQL Server, following the documentation, all probes started OK, except by sla_engine. The error message in logs is next:

Jun 24 00:32:09:973 [main, sla_engine] Resulting parsed connection data is: DatabaseConnectionInfo [databaseName=CA_UIM, databaseServer=uimdb.production.com, dbProvider=SQLNCLI11, nisJdbcUsername=uimuser, nisJdbcPassword={not_shown_for_security_reasons}, nisJdbcUrl=jdbc:sqlserver://;serverName=uimdb.production.com;databaseName=CA_UIM;applicationName=sla_engine;Network Library=dbmssocn;Language=us_english;Encrypt=true;TrustServerCertificate=false;trustStore=C:\Program Files (x86)\Nimsoft\security\truststore.jks;trustStorePassword={not_shown_for_security_reasons};]
Jun 24 00:32:09:973 [main, sla_engine] Connection string retrieved successfully from data_engine
...
Jun 24 00:32:10:344 [main, sla_engine] Exception occurs in createConnection com.microsoft.sqlserver.jdbc.SQLServerException: The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: "SQL Server did not return a response. The connection has been closed.". Trace: com.microsoft.sqlserver.jdbc.SQLServerException: The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: "SQL Server did not return a response. The connection has been closed.".
...
Caused by: java.io.IOException: SQL Server did not return a response. The connection has been closed.

Environment

Release : 20.1

Component : UIM - DATA_ENGINE

Cause

As mentioned in the log, the connection string is obtained from the data_engine.

If only the sla_engine is having problems to connect to the DB, using the same connection string as the other probes, probably there is an issue with the sla_engine probe.

Redeploying the latest release of the probe could make a difference.

Resolution

1. Deactivate the sla_engine probe from IM. Right click the probe and select Deactivate.

2. Once the probe turns gray, right click it again, and this time select Delete.

3. Delete the sla_engine directory probe (the path might be different if UIM was installed on a different directory)

4. From the IM archive check the latest version of the probe, and deploy it to the primary hub. It might be worth to check also if there is a newer version of the probe in here.

5. Once deployed, please activate the sla_engine probe. This time it should start OK. 

Additional Information

1. CA Unified Infrastructure Management Hotfix Index

2. Support for TLS v1.2 (Microsoft SQL Server)