After upgrade PM unable to communicate with Proxy
search cancel

After upgrade PM unable to communicate with Proxy

book

Article ID: 218791

calendar_today

Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

ERROR | qtp343100730-22          | 2024-07-01 16:27:50,238 | com.ca.im.portal.api.services.datasource.DataSourcePoll          
      | Received WebServiceException from version check for data source Data [email protected].  CAUSE=org.apache.cxf.transport.http.HTTPException: HTTP response '503: Service Unavailable' when communicating with http://lab.company.com:8581/DataSourceWS. MESSAGE=Could not send Message..  Returning DS_COMM_FAILURE result.

FT DA not connecting to proxy after upgrade 

Fault Tolerant Data Aggregator not connecting to proxy after upgrade 

503: service unavailable

Environment

Release : All Supported Releases

Component : DA Proxy

Cause

Hostname for one of the Data Aggregators in the /opt/CA/daproxy/conf/daproxy.toml file was incorrect in the [http.services] section. 

There were 2 references to the wrong name.

Resolution

One of the Data Aggregators names was entered wrong during the upgrade.

Fixed the name in the /opt/CA/daproxy/conf/daproxy.toml file 

recycle services: daproxy and consul on proxy host

recycle services on both DA's: consul and consul-ext