iSeries Robot fails to start - Controller: send_internal_alarm: sockConnect failed
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iSeries Robot fails to start - Controller: send_internal_alarm: sockConnect failed

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Article ID: 218739

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Getting sockConnect failed when trying to start the robot agent.

Jun 21 15:50:24:875 Controller:  Name   = -----, IP = --.--.-.--, Port = 48000
Jun 21 15:50:24:875 Controller:  OS     = IBM / AS400 / AS400
Jun 21 15:50:24:875 Controller:  Domain = none
Jun 21 15:50:24:875 Controller:  Loglevel = 0, Logfile = controller.log
Jun 21 15:50:24:876 Controller:  Running as user NIMBUS (640)
Jun 21 15:50:24:876 Controller: ----- 
Jun 21 15:50:24:884 Controller: Controller on ------ port 48000 started
Jun 21 15:50:24:892 Controller: send_internal_alarm: sockConnect failed

Even with robot.cfg configured to use a different port and log level it always shows the same. 

Environment

Release : 20.3

Component : UIM - ISERIES_ROBOT_UPDATE

Cause

The OS is configured for the Primary language of Japanese and Secondary language of English 

System CCSID is something other than 65535. 

Resolution

On the AS400: 


create the user NIMBUS:
CRTUSRPRF USRPRF(NIMBUS) PASSWORD()
USRCLS(*SECOFR) TEXT('Nimbus User for Nimsoft Management')


Create temporary files for the 'save files'

For English,  the Nimbus ID and the ID/profile doing the restore of the Nimbus software and IFS (if different than Nimbus) needs to have it’s CCSID set to 37 (English).

For successful install the Nimbus ID and the ID/profile doing the restore of the Nimbus software and IFS (if different than Nimbus) needs to have Language ID (keyword: LANGID) set to ENU and Country or Region ID (keyword: CNTRYID) set to US.