Error: ???key: 8100??? Manage Offline Endpoint Configuration
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Error: ???key: 8100??? Manage Offline Endpoint Configuration

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Article ID: 218692

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Updated On:

Products

CA Identity Manager

Issue/Introduction

When access Manage Offline Endpoint Configuration it shows the error "Error: ???key: 8100???"

 

Environment

Release : 14.3

Standalone
5 node cluster
Oracle 18
14.1 to 14.3 CP2 in-place upgrade
No Siteminder

Component : IdentityMinder(Identity Manager)

Cause

14.3 CP2 where a client had custom Workpoint workflows.  It is believed they overwrote their workflows with their custom ones on import.  This exposed this error Error ???key 8100??.  It was found in 14.3CP2 there is no 8100 in identitymanagerexceptions.properties.

Resolution

Added the following to IdentityManagerExceptions.properties.

The "IdentityManagerExceptions.properties" file is located under the folder

For standalone

X:\...\standalone\deployments\iam_im.ear\custom\provisioning\resourceBundles

 

For vApp

/opt/CA/VirtualAppliance/custom/IdentityManager/custom/provisioning/resourceBundles

 

#Messages from Id 8100 - 8200 reserved for offline endpoint management

8100=Event {0} is not mapped to workflow process {1}. Unable to continue.

8101=Offline Endpoint Management is disabled for the environment.

 

Note: If you are using a different language than English, change the correspondent file as well, for example, for Spanish the file is "IdentityManagerExceptions_es.properties"

Additional Information

In 14.4 the IdentityManagerExceptions.properties contain the 8100 records and will display the error properly if all default workflows are deleted where offline endpoint would then display "8100=Event {0} is not mapped to workflow process {1}. Unable to continue." as expected.