Troubleshooting failed discover file target scans.
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Troubleshooting failed discover file target scans.

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Article ID: 218626

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Updated On:

Products

Data Loss Prevention

Issue/Introduction

Troubleshooting failed discover file target scans.

Environment

Tested under 15.1 but will happen on all DLP versions.

Cause

Discover file target file fails.

Resolution

Log into the discover server as the user configured for the discover scan then access the share from Windows Explorer

If that works you will need to access by command line using the following command: net use z: "\\<sharename>\C$" PASSWORD /user:USERNAME /persistent:no

If you receive the error "System error 85 has occurred: the local device name is already in use", you will need to delete the connection and connect again to the share. You will need to run the command: net use drive letter /delete then run the command: net use z: "\\<sharename>\C$" PASSWORD /user:USERNAME /persistent:no If you are not able to connect the issue is not DLP. You will want to contact your System/Network/Domain admins to help fix the issue with the share. If your admins do not find issues please continue this document to gather more troubleshooting information.

Navigate to System\Servers and Detector\Logs Then click on Configure Logs.

Select your Discover server in the first drop down and Discover Trace Logging in the second drop down. Then click on Configure Logs.

 

Run the Discover scan.

 

Navigate to System\Server and Detectors\Logs

 

Select the first 3 boxes for the discover server and click collect logs.

 

Download the logs.

 

Look at the scan details logs below to see what happened during the scan. Look at the FileReader logs for warnings and severe messages. Look at the FileReader logs for messages indicating which batch file is being used.

Search for Command Standard Output. This will be the Windows or Linux error that happened.

Use this document to know the command being used to connect to the share. You will want to use this command to connect to the share. https://knowledge.broadcom.com/external/article?articleId=160747 smb.bat is the most common used batch file used. The example of the command syntax would be net use z: "\\<sharename>\C$" PASSWORD /user:USERNAME /persistent:no If you get the same error from the command line you will need to work with your SYS Admins