Symantec Identity Manager - Intermittent Socket closed error
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Symantec Identity Manager - Intermittent Socket closed error

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Article ID: 218616

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Updated On:

Products

CA Identity Manager

Issue/Introduction

Identity Manager is intermittently throwing socket closed errors.

Error Message: javax.naming.ServiceUnavailableException: IPAddress:636; socket closed; remaining name

com.netegrity.llsdk6.imsapi.exception.SmApiWrappedException: [facility=6 severity=3 reason=0 status=0 message=Wrapped Exception: IPAddress:636; socket closed]
IPAddress:636; socket closed

Environment

Release : 14.X

Component : IdentityMinder(Identity Manager)

Cause

This can sometimes be caused by network latency and missing configurations on IDM and IMPS to alleviate the chances of occurance.

Resolution

Go to Wildfly installation location and open the standalone.bat (..\wildfly-8.2.0.Final\bin\standalone.bat)

Navigate to line:

set "SERVER_OPTS=%SERVER_OPTS% -c %STANDALONE_CONFIGURATION% -b %BIND_ADDRESS% %IDM_OPTS% -Djboss.as.management.blocking.timeout=900"

Update it to

set "SERVER_OPTS=%SERVER_OPTS% -c %STANDALONE_CONFIGURATION% -b %BIND_ADDRESS% %IDM_OPTS% -Djboss.as.management.blocking.timeout=900 -Dcom.sun.jndi.ldap.connect.pool.timeout=120000"

2) Confirm that "idletimeout=unlimited" within the ../ProvisioningServer/data/im_ps.conf