Bad Gateway after CDD QA Upgrade
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Bad Gateway after CDD QA Upgrade

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Article ID: 218607

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Updated On:

Products

Continuous Delivery Director

Issue/Introduction

After upgrading the CDD QA server from 6.9 to 8.2, the CDD Server/URL was not responsive. Trying to load the load balanced URL would just sit there spinning until it finally received:

Bad Gateway

Processing of this request was delegated to a server that is not functioning properly.

 

 

Environment

Release : 8.2

Component : CONTINUOUS DELIVERY DIRECTOR

 

Cause

In the Tomcat8.5\logs\tomcat8-stderr.2021-06-15.log we found the following messages:

... Unexpected death of background thread [ContainerBackgroundProcessor[StandardEngine[Catalina]]]

java.lang.OutOfMemoryError: Java heap space

 

Resolution

Add more memory to Tomcat. To do this we followed these steps:

  • Stop Tomcat.
  • Run tomcat_install/bin/Tomcat8w.exe and change the following values from the Java tab:
    • Initial memory pool: 2048
    • Maximum memory pool: 4096
  • Start Tomcat. 

 

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