Cannot access documents or export lists stored on Clarity server with https enabled
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Cannot access documents or export lists stored on Clarity server with https enabled

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Article ID: 218493

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

Problem Statement: We have enabled https in our dev environment. Whenever we try to access a document stored on the Clarity server (e.g., from the Knowledge Store or from a document search result) or whenever we try to export a list, we are brought to the CSA login page. We also have reverse proxy sitting in between and SSL is processed at reverse proxy. 

Steps to Reproduce

  1. Configure clarity to run on https by updating HTTP Entry URL and fill in the HTTPS URL ( This is done as SSL is terminated at reverse proxy and not at clarity app server)
  2. Configure SSL handing to use  SSL is used but processed externally
  3. Restart all the clarity services 
  4. Login to Clarity and Navigate to Knowledge Store and try to download an existing document

Expected Result: Document from knowledge store should be downloaded to the client computer.

Actual Result: User is navigated back to CSA login page 

Environment

Release : All Support Clarity Release 

Component : CLARITY INTEGRATIONS & INSTALLATIONS

Cause

During investigation it was found that configuration in the reverse proxy was incorrect. In this specific case 

 

 

Resolution

The first two lines need to be removed as that is forwarding the /niku/app traffic to the CSA service.After removal everything worked as expected.

  ProxyPass /niku/app http://Reverseproxy.xyz.com:8090/niku/app
  ProxyPassReverse  /niku/app http://Reverseproxy.xyz.com:8090/niku/app


  ProxyPass / http://Reverseproxy.xyz.com:8080/
  ProxyPassReverse / http://Reverseproxy.xyz.com:8080/