Processes do not start intermittently
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Processes do not start intermittently

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Article ID: 218472

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

We are experiencing a problem where processes are not starting intermittently. The same processes start at other times. Further we face this issue only in one of our environments.

Environment

Version: 15.8.1

Cause

The following error was noticed in the bg-ca.log:

Error message: [CA Clarity][SQLServer JDBC Driver][SQLServer]Transaction (Process ID 65) was deadlocked on lock resources with another process and has been chosen as the deadlock victim. Rerun the transaction.
Executed:
 UPDATE BPM_RUN_OBJECTS
          SET PARENT_OBJECT_ID = (SELECT ID FROM BPM_RUN_OBJECTS WHERE OBJECT_NAME = ? AND PK_ID = ? AND TABLE_NAME = ?)
          WHERE OBJECT_NAME = ? AND PK_ID = ? AND TABLE_NAME = ? 

Resolution

This is caused by an issue in the DB. Request the DBA to look into the BPM_RUN_OBJECTS table, for problems such as fragmentation or bad execution plan.