APM - Alert is not being propagating to team center even though the option is selected in the alert definition
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APM - Alert is not being propagating to team center even though the option is selected in the alert definition

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Article ID: 218449

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Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

Alert not propagating to team center. Action (SMTP notification) works, which confirms alert is triggered and the option is selected on the alert definition

 

Environment

Release : 10.7.0

Component : Integration with APM

Cause

The mapping for alerts from Introscope to Team Center is controlled by the file teamcenter-status-mapping.properties

 

The alert that the customer had defined was triggered against a JMX metric which by default is not mapped 

Resolution

Here is a worked example of how to configure this 

An alert is defined against a metric under the agent JMX Metric branch
JMX\|Default\|Catalina\|name="http\-nio\-8070"\|type=ThreadPool:connectionCount



Added the following entry to the default team-center-mapping.properties file

AGENT.10=JMX|*|*|*|type=ThreadPool

and the alert then propagated to the map