Export to CSV fails without any error when trying to export large amount of data via modern UX
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Export to CSV fails without any error when trying to export large amount of data via modern UX

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Article ID: 218405

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Export to CSV fails without any error in the job logs when trying to export large amount of data via modern UX

STEPS TO REPRODUCE: 

Note: In order to reproduce this issue, 100+ attributes are needed on customer investments and more than 500 custom investments instance

  1. Login to Clarity and Navigate to Moderx UX
  2. In the modern ux navigate to customer investments
  3. Create around 500+ custom investments instance
  4. On the gridview of custom investments add more than 100 and save the view
  5. Use the Export to CSV button to export the data saved in the view using step 4 

Expected Results: The Export to CSV should be successful 

Actual Results:Export to CSV fails with no error log entries on the job logs (The Async Export to CSV Job triggers only when the number of instance are more than 500 else export will be real time only) 

  • On the notification bell in the modern ux you will see the error Could not export CSV - View 

  • Once the job fails you can navigate to Reports & Jobs and under Jobs --> Logs (look for Export to CSV JOB and check failed jobs) . The log entries sub section no entries will be seen and even in logs nothing will be shown 

 

Environment

Release : 15.9.2

Cause

This is a defect DE61528 

Resolution

  • The defect DE61528 is fixed in 16.0 
  • The Export to CSV in the gridview is meant not for large data extraction and recommended to limit the number of columns of 50 and export 
  • The Export to CSV also has governor limits defined and can be found in Heath Report (Administration --> Security & Diagnostic --> Health Report)