Cannot start linux agent from command line
search cancel

Cannot start linux agent from command line

book

Article ID: 218378

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

Attempting to start a linux agent from the servicemanager (smgr or service manager), the service manager dialog does not show any activity.  Checking the service manager log shows something like:

20210628/142427.409 - U00022004 Starting process 'UC4 UNIX01' ...
20210628/142427.409 - U00022005 ... with command line  '/opt/Automic/Agents/unix/bin/ucxjlx6'.
20210628/142427.409 - U00022006 ... and start directory  '/opt/Automic/Agents/unix/bin/'.
20210628/142427.410 - ERROR: errno '2' returned: No such file or directory
20210628/142427.410 - U00022007 Process 'UC4 UNIX01' (ID '159353') successfully started.
20210628/142427.410 - U00022012 Process 'UC4 UNIX01' (ID '159353') ended.
20210628/142427.410 - U00022022 Process 'UC4 UNIX01' ended, exit code='0'.

Environment

Release : 12.3

Component : AUTOMATION ENGINE

Cause

This is caused by the incorrect command and/or startpath being used for the agent - in the example above, the directory the smgr is using is

/opt/Automic/Agents/unix/bin

but it should be:

/opt/Automic/Agents/linux/bin

Resolution

  1. From the OS, navigate to the agent's bin directory and note the path with a pwd command:
    example:
  2. In the Service Manager Dialog, right-click on the agent and choose Properties:
  3. Update the Command and Startpath to include the directory path from step 1 above:

Attachments