No Matching Ticket Artifact was found debug error with Maileater
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No Matching Ticket Artifact was found debug error with Maileater

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Article ID: 218366

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Experiencing issues creating ticket via maileater.  Finding that once maileater connects to its mailbox, the mail is being processed, but no actual ticket is created.

Environment

Release : 17.3

Component : SERVICE DESK MANAGER

Cause

Examining the maileater_nxd.log with debugging enabled, at 2021-06-25 15:39:27:910, 6 emails were processed and each time, this was what was generated per message:

2021-06-25 15:39:30:576 DEBUG  [ForkJoinPool-1-worker-3] c.c.S.m.MailboxRule - [Maileater Test:400053]  Filter match Found : [ \t\r\n]*[ \t\r\n]
2021-06-25 15:39:30:576 DEBUG  [ForkJoinPool-1-worker-3] c.c.S.m.MailboxRule - [Maileater Test:400053] No Matching Ticket Artifact was found.
2021-06-25 15:39:30:583 DEBUG  [ForkJoinPool-1-worker-3] c.c.S.m.MailboxRule - [Maileater Test:400053] Posting message to Text_API.
2021-06-25 15:39:30:583 DEBUG  [ForkJoinPool-1-worker-3] c.c.S.m.JavaMailParser - [Maileater Test:400053] Successfully processed the Email Message

The above suggests that the mails are being read and are tripping on a filter rule that should generate the ticket.  But what happens instead is that no ticket is created. 

The key message here is the "No Matching Ticket Artifact was found" entry in the above logging.  That means the stdlog may hold additional clues to why the creation of such a ticket had failed.

In looking at the stdlogs, there are six instances of this exact error message, which matches the 6 attempts to create an Issue:

06/25 15:39:30.70 SERVER1 spelsrvr                4476 ERROR        cr_chg_text_api.spl   1420 AHD58009:Could not create Issue. Reason: INVALID - AHD03075:Required attribute Priority is missing from object Issue

The concern here is that maileater that did not specify the Priority value as a required field for Issues.

Resolution

Based on the above analysis, one should send a mail message that includes this text in the message body to default the priority field.

%PRIORITY=4