Unable to list complete REST Webservice API
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Unable to list complete REST Webservice API

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Article ID: 218350

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Updated On:

Products

CA Service Desk Manager

Issue/Introduction

Unable to update Change Order  ticket using REST Webservice API ( Table: chg) 
Excerpt from Jrest.log: 
06/10 12:16:24.068 [http-nio-8050-exec-2] ERROR DalUtilities 183 Invalid REST Access Key (null) provided via X-AccessKey header. 
06/10 12:16:24.069 [http-nio-8050-exec-2] ERROR SDMCRUDServiceImpl 1283 Error retrieving details for 'chg' resource identified by 'chg_ref_num LIKE 'C604216''. Invalid REST Access Key (null) provided via X-AccessKey header. {http://server-name:8050/caisd-rest/chg/COMMON_NAME-C604216} 

Unable to list the complete REST webservice API using POSTMAN: 


Environment

Release : 17.3.X

Component : SERVICE DESK MANAGER

Cause

Pojo & Service folder were corrupted. 

Resolution

Step1 : Please take a  backup copy of your existing  WEB-INF folder: 
Location: C:\Program Files (x86)\CA\Service Desk Manager\bopcfg\www\CATALINA_BASE_REST\webapps\caisd-rest\WEB-INF  

Step2 : pdm_tomcat_nxd -c stop -t REST

Step 3: Copy  the content of pojo from working server to non-working server ( same location) : 
C:\Program Files (x86)\CA\Service Desk Manager\bopcfg\www\CATALINA_BASE_REST\webapps\caisd-rest\WEB-INF\classes\com\ca\ServicePlus\rest\sdm\pojo

Step 4:Copy  the content of service from working server to non-working server ( same location) : 
C:\Program Files (x86)\CA\Service Desk Manager\bopcfg\www\CATALINA_BASE_REST\webapps\caisd-rest\WEB-INF\classes\com\ca\ServicePlus\rest\sdm\service. 

Step 5 : pdm_tomcat_nxd -c start -t REST

Step6 : Use postman to check wadl : http://servername:8050/caisd-rest/?_wadl.