Introscope agent errors keeping application from starting
search cancel

Introscope agent errors keeping application from starting

book

Article ID: 218323

calendar_today

Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

We are using the Java agent on several Springboot apps.  After patching, the Java version was updated from OpenJDK version "1.8.0_242" to OpenJDK version "1.8.0_292" and now the application will not start with the Introscope agent enabled.  

 

Environment

Release : 10.2.0 Agent

Component : Integration with APM

Resolution

https://stackoverflow.com/questions/54804355/java-lang-verifyerror-stack-map-does-not-match-the-one-at-exception-handler

-Xverify:none 

Additional Information

Or upgrade Agent to 10.7 and later